OrbiCam finalmente supportata!


Finalmente la mia webcam integrata, su Acer Aspire 5634WLMi, è supportata dai drivers gspca!!!

Allora, per prima cosa cerchiamo di capire come identificare la webcam, da terminale digitare:
lsusb
se tra i dispositivi elencati troviamo:
Bus 001 Device 002: ID 046d:0896 Logitech, Inc.
allora è lei! :D

Per prima cosa dobbiamo predisporre l’ambiente installando i kernel-headers ed il pacchetto build-essential, quindi:
sudo apt-get install build-essential linux-headers-$(uname -r)
quindi colleghiamoci al sito per eseguire il download del pacchetto gspcav1-20061216.tar.gz quindi posizioniamoci nella cartella dove abbiamo eseguito il download:
cd /path/cartella/download
e scompattiamo il pacchetto:
tar zxvf gspcav1-20061216.tar.gz
quindi non resta altro che:
cd gspcav1-20061216/
make
sudo make install

ora andiamo a modificare il file /etc/modprobe.d/options :
sudo gedit /etc/modprobe.d/options
ed inseriamo alla fine
options gspca force_rgb=1
non resta altro che caricare il modulo:
sudo modprobe gspca
e controllare che il dispositivo sia stato creato
ls /dev/video*
se così non fosse, controllare l’output di
dmesg|tail -30
Ora con camorama
sudo apt-get install camorama
possiamo finalmente usare la nostra webcam!

Buon divertimento! ;)

About these ads

148 Responses to OrbiCam finalmente supportata!

  1. sturi scrive:

    TUTTO PERFETTO!
    Grazie!

  2. freedreamer scrive:

    Bus 003 Device 002: ID 0402:5602 ALi Corp.
    Ancora nulla sul mio acer 5102…
    maledetta ACER!

    bella guida cmq :)

  3. miguelx scrive:

    Thanks!! stavo disperando…
    Sul mio 5685 mancano ancora all’appello il lettore di card ( ENE Technology) e l’attivazione dal bios del VT…

  4. Vincenzo scrive:

    Stesso acer di freedreamer e confermo che pure da me non funziona la webcam, visto che non viene creato il dispositivo /dev/video..

    In ogni caso guida ottima ;)

  5. PeppeMessoMalex scrive:

    Grazie mille per la guida ;), funziona perfettamente su Acer Aspire 5672

  6. Sarastro scrive:

    Penso di amarti :P
    Bravissimo

  7. davide scrive:

    sei un genio ti voglio bene.
    funziona su acer aspire serie 1640
    ciao

  8. clhona scrive:

    mi associo agli altri commenti…mitico! funziona sul mio aspire 5610
    grazie ciao ciao

  9. monica scrive:

    Ehhh, it doesn’t work with my Acer Aspire 3692. If I make lsusb I’ve got:
    Bus 4 Device 1: ID 0000:0000
    Bus 5 Device 2: ID 0402:5602 ALi Corp.
    Bus 5 Device 1: ID 0000:0000
    Bus 3 Device 1: ID 0000:0000
    Bus 1 Device 1: ID 0000:0000
    Bus 2 Device 1: ID 0000:0000

    No Logitech. I’ve installed gspca driver and load module but Acer OrbiCam doesn’t work. Can anybody help me?

  10. paper0k scrive:

    I’m sorry, but I think this isn’t supported by gspca driver, you can see a list of supported webcams here
    http://mxhaard.free.fr/spca5xx.html ;)

  11. Paolino86 scrive:

    ho eseguito la procedura fino in fondo ma sul mio acer aspire 5101 non va ancora niente…quando apro camorama mi compare il messaggio:
    Could not connect to video device (/dev/video0). Please check connection.
    che devo fare?

  12. paper0k scrive:

    Hai controllato che l’output di lsusb sia lo stesso che ho riportato nel post? ;)

  13. Paolino scrive:

    no non è lo stesso ma ho provato a fare qualche aggiustamento per vedere se lo prendeva uguale…qualche suggerimento?
    io il mio collegamento l’ho visto con “lspci”\

  14. paper0k scrive:

    Prova allora a fare una ricerca su Google o meglio sul forum italiano di Ubuntu (http://forum.ubuntu-it.org) con l’output di lspci/lsusb per la tua webcam ;)

  15. Paolino scrive:

    ho cercato ma ho visto solo i tuoi interventi. :-) e mi rimandano qua…uff…mi sa che mi tocca aspettare…SGRUNT :-S

  16. mr.pinky scrive:

    tutto fatto, ma quando comando: ls /dev/video non mi trova il file video….

  17. paper0k scrive:

    MMM… sicuro che la webcam rilevata da lsusb sia questa?
    Bus 001 Device 002: ID 046d:0896 Logitech, Inc. ;)

  18. mr.pinky scrive:

    E’ una ricoh su un VAIO VGN AR-21B…. però ho letto su altri forum che il gspca funziona anche su VAIO FE…. Sai darmi qualche dritta??? Tnx!

  19. paper0k scrive:

    Con l’output di “lsusb” controlla qui http://mxhaard.free.fr/spca5xx.html se la webcam è supportata ;)

  20. adam scrive:

    miticoooooooooooooooooo!
    dopo 6 mesi anche la mia orbishit funziona grazie a te.

  21. Ext2 scrive:

    Cakkio la mia ancora non è supportata!!

    Paperok!!!

    Mi tocca aspettare ancora un pochino (si spera)
    visto che l’out di lsusb è questo :

    Bus 005 Device 003: ID 046d:0896 Logitech, Inc.
    :(

  22. paper0k scrive:

    No, è come la mia, quindi la guida dovrebbe andare, prova ;)

  23. Ext2 scrive:

    Pape0k non ci sto capendo niente tra qui e la :D
    ps tu mi hai capito vero :P

    cmq fammi spere qualcosa al piu presto ok???

    Grazie anticipate :D

  24. nidzo scrive:

    help!
    ieri ho provato la procedura: tutto perfetto, funzionava! oggi accendo il computer e non va più. mi dice Could not connect to video device (/dev/video0). Please check connection.
    noto tra parentesi che il led della webcam è sempre acceso……
    /dev/video0 c’è….

    l’output del mio lsusb è:
    Bus 005 Device 003: ID 046d:0892 Logitech, Inc.

    come quello di ext2. però ieri funzionava….
    mha!?
    nidzo

  25. paper0k scrive:

    @nidzo
    Ti consiglio di aprire un post su http://forum.ubuntu-it.org con la segnalazione (così sarà più semplice darti un supporto), ed inserire poi qui il link della discussione, occorre approfondire per cercare di capire cosa succede.
    Usi camorama? Avvialo da terminale così vedi se ci sono errori ed inserisci nel topic anche l’output di
    dmesg |grep gspc ;)
    @Ext2
    Penso sia meglio continuare sul forum :)

  26. Carluz scrive:

    Personalmente ho fatto funzionare subito la webcam, io ho un aspire 9113, ma si vede veramente male.
    Avete per caso poi tra l’altro visto che non c’è nessuna differenza se si modifica la option del modulo?
    A voi come si vede rispetto a windorf ad esempio?

    Carluz

  27. nidzo scrive:

    con un certo ritardo, allego il mio dmesg.
    sì, uso camorama, e lo lancio sempre da terminal. l’output mi dice could not connect to device /dev/video0 anche se /dev/video0 esiste….

    ho provato a ripetere la procedura di installazione del driver, ma dopo il successo iniziale, la webcam non ha più funzionato….
    ciao
    nidzo

    nidzo@nidzo-laptop:~$ dmesg |grep gspc
    [17179591.592000] /home/nidzo/gspcav1-20070110/gspca_core.c: USB SPCA5XX camera found.(VC0321)
    [17179591.592000] /home/nidzo/gspcav1-20070110/gspca_core.c: [spca5xx_probe:3983] Camera type YUYV
    [17179591.800000] /home/nidzo/gspcav1-20070110/Vimicro/vc032x.h: [vc032x_probe_sensor:128] check sensor header 44
    [17179591.816000] /home/nidzo/gspcav1-20070110/Vimicro/vc032x.h: [vc0321_config:350] Find Sensor PO3130NC
    [17179591.816000] /home/nidzo/gspcav1-20070110/gspca_core.c: [spca5xx_getcapability:1189] maxw 640 maxh 480 minw 176 minh 144
    [17179591.816000] /home/nidzo/gspcav1-20070110/gspca_core.c: data format set to RGB
    [17179591.816000] usbcore: registered new driver gspca
    [17179591.816000] /home/nidzo/gspcav1-20070110/gspca_core.c: gspca driver 01.00.12 registered
    [17179648.384000] /home/nidzo/gspcav1-20070110/gspca_core.c: [spca5xx_set_light_freq:1858] Sensor currently not support light frequency banding filters.
    [17179648.384000] /home/nidzo/gspcav1-20070110/gspca_core.c: [gspca_set_isoc_ep:881] ISO EndPoint found 0×82 AlternateSet 7

  28. paper0k scrive:

    @Carluz
    Ma è un problema di colori? Se così, avevo notato anche io il problema ed ho risolto con “options gspca force_rgb=1″ in /etc/modprobe.d/options, come riportato nel post ;)

    @nidzo
    Il driver sembra andare… prova a controllare effettivamente il device che ha creato:
    ls /dev/video*
    forse devi solo cambiare il putamento di camorama ;)

  29. nidzo scrive:

    come device ho /dev/video0 e /dev/video, che è un link al precedente. nessuno dei due funziona, nè con camorama, nè con camstream. stesso messaggio di errore. il fatto è che il led della webcam è acceso. sembra che i programmi non possano accedere al device perchè già occupato. ma sono troppo ignorante per capire se è così.
    non so poi se può essere utile provare gli altri driver al link dove ho scaricato il gspcav1-20070110

    ciao
    nicco

  30. paper0k scrive:

    @nidzo
    Ok, penso che il driver funzioni, prova a lanciare:
    gksu camorama
    non vorrei fosse solo un problema di permessi… intanto posta l’output di
    ls -l /dev/video* ;)

  31. nidzo scrive:

    gksu camorama mi da lo stesso messaggio di errore (could not connect…..)

    ls -l /dev/video*
    lrwxrwxrwx 1 root root 6 2007-02-14 23:19 /dev/video -> video0
    crw-rw—- 1 root video 81, 0 2007-02-14 23:19 /dev/video0

  32. paper0k scrive:

    @nidzo
    Il driver è riconosciuto, i permessi sono corretti… e continua a darti errore persino da root… l’unica differenza tra la mia e tua situazione è la versione del driver gspca, io uso la gspcav1-20061216 mentre tu gspcav1-20070110… spiacente ma al momento non mi viene in mente altro, prova a postare il problema sul forum http://forum.ubuntu-it.org/

  33. nidzo scrive:

    i casi……
    stavo cercando di installare beryl. inutile dire che non mi funzionava, credo ci sia qualche problema di scheda video. ad ogni modo, tra i vari pacchetti c’era anche un driver che non doveva esserci. per cui provo a tornare indietro, e nella procedura synaptic mi toglie anche i kernel headers (o qualcosa del genere). di fatto anche la webcam risulta disinstallata (e il led è spento). morale, ripeto le tue istruzioni di installazione, e…… funziona! (sepre lo stesso driver gspcav1-20070110). led spento, quando lancio camorama si accende e funziona….
    ora: spero solo che senza toccare altro, al prossimo riavvio funzioni!!!!

    il dmesg non sembra cambiato….
    [17181153.308000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: USB SPCA5XX camera found.(VC0321)
    [17181153.308000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: [spca5xx_probe:3983] Camera type YUYV
    [17181153.516000] /home/nidzo/salvati/gspcav1-20070110/Vimicro/vc032x.h: [vc032x_probe_sensor:128] check sensor header 44
    [17181153.536000] /home/nidzo/salvati/gspcav1-20070110/Vimicro/vc032x.h: [vc0321_config:350] Find Sensor PO3130NC
    [17181153.540000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: [spca5xx_getcapability:1189] maxw 640 maxh 480 minw 176 minh 144
    [17181153.540000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: data format set to RGB
    [17181153.540000] usbcore: registered new driver gspca
    [17181153.540000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: gspca driver 01.00.12 registered
    [17181170.444000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: [spca5xx_set_light_freq:1858] Sensor currently not support light frequency banding filters.
    [17181170.444000] /home/nidzo/salvati/gspcav1-20070110/gspca_core.c: [gspca_set_isoc_ep:881] ISO EndPoint found 0×82 AlternateSet 7

    vi farò sapere….
    intanto, comunque, grazie.
    nidzo

  34. paper0k scrive:

    Grande! Finalmente una bella notizia ;)

  35. JPJuchem scrive:

    Fantastic! Clear! Easy!

    Thank you very much! Everything works perfectly.

    Abraços de Porto Alegre/RS/Brasil.

  36. nidzo scrive:

    riavviato il computer….. tutto come prima!
    sorry
    nidzo

  37. paper0k scrive:

    @nidzo
    Non ho capito, quindi è risolto?

  38. nidzo scrive:

    no, non funziona.
    il device risulta busy. c’è un modo per stopparlo? in questo caso forse potrei stopparlo manualmente e riavviarlo con camorama…..

    in compenso, beryl funziona: niente male.
    nidzo

  39. paper0k scrive:

    Prova a fare
    sudo modprobe -r gspca
    sudo modprobe gspca
    e vedi se così va ;)

  40. roby scrive:

    scusate la mia ignoranza…ma dove devo digitare lsusb??
    io ho aspire 5672 e la webcam non funziona.
    grazie

  41. paper0k scrive:

    Apri un terminale e digiti
    lsusb
    e premi INVIO ;)

  42. roby scrive:

    ho provato a digitarlo dal prompt dei comandi,da”esegui”(da start)….
    aiutami..non ho capito!

  43. paper0k scrive:

    @roby
    Se usi GNOME vai sul menu Applicazioni–>Accessori–>Terminale
    Se sei alle prime armi con Ubuntu ti consiglio di leggere la documentazione riportata qui http://forum.ubuntu-it.org/index.php/topic,43655.0.html ;)

  44. roby scrive:

    grazie paperOK…ora la leggo cosi imparo qualcosa!!

  45. nidzo scrive:

    sudo modprobe -r gspca
    sudo modprobe gspca

    non funziona, perchè mi dice che il device è occupato.

    ho provato anche a installare il driver precedente (2006…) ma non cambia nulla.
    dovessi riuscire, vi farò sapere…

    nidzo

  46. nidzo scrive:

    !!!!!
    risolto!!!! (penso)

    tempo fa, avevo installato anche camstream e camserv (insomma, avevo installato tutto ciò che sembrava connesso ad una webcam).
    credo che fossero loro a fare pasticci. ora li ho eliminati e il led si è spento, e la webcam funziona…..
    spero di non avere sorprese all’ormai fatidico prossimo riavvio….

    scusa per la perdita di tempo, magari però queste informazioni possono servire a qualche altro impedito….

    ciao
    nicco

  47. Andre scrive:

    tutto ok, a parte l’ultimo comando.
    quando digito “sudo apt-get install camorama”
    ricevo in risposta questo output

    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Reading state information… Fatto
    E: Impossibile trovare camorama

    Sapresti aiutarmi???
    Andre

  48. paper0k scrive:

    @Andre:
    Controlla se è attivo il repository Universe ;)

  49. Andre scrive:

    Ok tutto funzionante…
    mitico!!!!!!

    ciao
    Andre

  50. Mianonnainscufia scrive:

    Complimenti funziona benissimo sul mio Aspire 5630!!!!!!!!!1

    Grazie mille ^^

  51. daniele scrive:

    ho un acer aspire 5633wlmi e funziona perfettamente, ti ringrazio infinitamente. ciao

  52. Tonia scrive:

    Sul mio acer aspire 5670 ho problemi con la cam per quanto riguarda i video. Appena salvato il video nella cartella immagini, se vado ad aprire la suddetto cartellaviene visualizzato una messaggio di “protezione esecuzione programmi” che mi fa bloccare il computer. Cosa succede? e soprattutto come posso risolvere questo inconveniente?

  53. paper0k scrive:

    @Tonia: credo che il problema potrebbe essere nel sw che avvii per vedere i filmati, controlla se hai i codec necessari ed eventualmente prova a postare il problema nel forum ;)

  54. antony scrive:

    ho applicato alla lettera quanto indicato dalla guida.
    Tutto funziona sull’Aspire 5601 AWLMi, unico neo i
    colori che non sono il massimo (ma forse questo dipende
    dalla risoluzione della Orbicam)
    Grazie, ottimo howto.
    @antony

  55. ZarZ scrive:

    Ho seguito alla lettera, funziona, peccato però che non si vede molto bene…

  56. paper0k scrive:

    @ZarZ:
    Hai fatto la modifica al file /etc/modprobe.d/options?

    @Tutti:
    Piccolo aggiornamento, per Feisty, fate riferimento a questo post ;)

  57. spit scrive:

    tutto ok sul mio acer aspire 5633wlmi, bell’howto, comprensibile anche per un niubbo quale il sottoscritto. Una cosa sola non mi è chiara: camorama mi da un’immagine ben bilanciata, ma se registro tipo con mencoder

    mencoder tv:// -tv driver=v4l:width=640:height=480:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -o /home/spit/video/registrazioni/video.avi

    i colori sono sballati sul blu. Se qualcuno mi svelasse l’arcano sarei MOLTO felice. Grazie!

  58. paper0k scrive:

    Prova così
    mencoder tv:// -tv driver=v4l:width=640:height=480:device=/dev/video0:forceaudio:adevice=/dev/dsp -ovc lavc -oac mp3lame -lameopts cbr:br=64:mode=3 -vf rgb2bgr=swap,scale -o video.avi ;)

  59. spit scrive:

    graie mille, perfetto. Ho provato a spulciarmi da solo il manuale di mencoder, ma è una cosa enorme. Grazie ancora.

  60. francesca scrive:

    Grazie mille!

  61. spit scrive:

    scusate il disturbo, ma crdo di aver bisogno di un’altra dritta su una cosa che mi ha fatto proprio andare via di testa. Non so per quale motivo la mia orbicam, che prima non aveva nessun problema, oggi di punto in bianco mi da in output una finestra completamente verde, con camorama, mencoder o quant’altro. Questo è l’output di mencoder.
    MPlayer 2:1.0~rc1-0ubuntu9 (C) 2000-2006 MPlayer Team
    CPU: Intel(R) Core(TM)2 CPU T5500 @ 1.66GHz (Family: 6, Model: 15, Stepping: 6)
    CPUflags: MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
    Compiled with runtime CPU detection.
    Can't open joystick device /dev/input/js0: No such file or directory
    Can't init input joystick
    mplayer: could not connect to socket
    mplayer: No such file or directory
    Failed to open LIRC support. You will not be able to use your remote control.

    Playing tv://.
    TV file format detected.
    Selected driver: v4l
    name: Video 4 Linux input
    author: Alex Beregszaszi
    comment: under development
    Selected device: Logitech Orbicam
    Capabilites: capture
    Device type: 1
    Supported sizes: 176x144 => 640x480
    Inputs: 1
    0: VC0321: (tuner:0, norm:pal)
    Using input 'VC0321'
    ioctl get tuner failed: Invalid argument
    Selected input hasn't got a tuner!
    open: No such file or directory
    [MGA] Couldn't open: /dev/mga_vid
    open: No such file or directory
    [MGA] Couldn't open: /dev/mga_vid
    [VO_TDFXFB] Can't open /dev/fb0: No such file or directory.
    [VO_3DFX] Unable to open /dev/3dfx.
    Opening video filter: [scale]
    Opening video filter: [rgb2bgr=swap]
    ==========================================================================
    Opening video decoder: [raw] RAW Uncompressed Video
    VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
    Could not find matching colorspace - retrying with -vf scale...
    Opening video filter: [scale]
    VDec: using Planar YV12 as output csp (no 0)
    Movie-Aspect is undefined - no prescaling applied.
    SwScaler: using unscaled yuv420p -> rgb32 special converter
    VO: [xv] 640x480 => 640x480 Planar YV12
    Selected video codec: [rawyv12] vfm: raw (RAW YV12)
    ==========================================================================
    Audio: no sound
    Starting playback...

    grazie in anticipo

  62. paper0k scrive:

    MMM… hai installato nuove versioni del kernel o del driver? O pacchetti di terze parti? Hai provato a vedere da Win (o altro SO anche GNU/Linux) se comunque funziona?

  63. spit scrive:

    sul laptop ho solo linux, e non ho fatto modifiche significative. La cosa strana è che dopo un reboot non ho avuto cambiamenti, mentre dopo una notte di spegnimento andava di nuovo tutto. Boh…

  64. Argo scrive:

    ho un acer aspire 9300-5317 con una webcam bison e non riesco a farla funzionare, ho provato di tutto ma nisba, pensi di potermi aiutare?
    Grazie

  65. paper0k scrive:

    @Argo
    Se fai
    lsusb
    dovresti ottenere
    Bus 002 Device 002: ID 0402:5602 ALi Corp.
    e non sono gestiti da gspca… Credo siano gestiti da questo driver https://sourceforge.net/projects/m560x-driver/ ma non lo conosco e non so darti ulteriori dettagli in merito ;)

  66. spit scrive:

    mh… ho riavuto lo stesso problema. Ho dato un occhio in /dev e non c’è più video0, ovvero il device webcam. ho dato un dmesg|tail -30 e questo è l’output. Mi spiace ma sono abbastanza niubbo da non saperlo interpretare…

    spit@spit-laptop:~$ dmesg|tail -30
    [ 36.872000] Bluetooth: RFCOMM ver 1.8
    [ 40.060000] [drm] Initialized drm 1.1.0 20060810
    [ 40.064000] ACPI: PCI Interrupt 0000:00:02.0[A] -> GSI 16 (level, low) -> IRQ 17
    [ 40.064000] [drm] Initialized i915 1.6.0 20060119 on minor 0
    [ 58.532000] NET: Registered protocol family 10
    [ 58.532000] lo: Disabled Privacy Extensions
    [ 58.532000] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 58.532000] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 99.124000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 117.208000] eth1: no IPv6 routers present
    [ 160.116000] usb 3-2: new full speed USB device using uhci_hcd and address 10
    [ 160.236000] usb 3-2: device descriptor read/64, error -71
    [ 160.460000] usb 3-2: device descriptor read/64, error -71
    [ 160.676000] usb 3-2: new full speed USB device using uhci_hcd and address 11
    [ 160.796000] usb 3-2: device descriptor read/64, error -71
    [ 161.020000] usb 3-2: device descriptor read/64, error -71
    [ 161.236000] usb 3-2: new full speed USB device using uhci_hcd and address 12
    [ 161.652000] usb 3-2: device not accepting address 12, error -71
    [ 161.764000] usb 3-2: new full speed USB device using uhci_hcd and address 13
    [ 162.180000] usb 3-2: device not accepting address 13, error -71
    [ 264.448000] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 311.120000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 311.800000] Linux video capture interface: v2.00
    [ 311.808000] usbcore: registered new interface driver gspca
    [ 311.808000] ubuntu/media/gspcav1/gspca_core.c: gspca driver 01.00.12 registered
    [ 328.056000] eth1: no IPv6 routers present
    [ 363.384000] ADDRCONF(NETDEV_UP): eth1: link is not ready
    [ 369.644000] ADDRCONF(NETDEV_CHANGE): eth1: link becomes ready
    [ 380.432000] eth1: no IPv6 routers present
    [ 392.608000] eth1: no IPv6 routers presen

  67. paper0k scrive:

    MMM… molto strano… da un errore di accesso ad un device usb ma comunque carica il driver gspca… ma è una webcam integrata? Altrimenti potrebbe essere un problema di alimentazione… inoltre hai fatto degli aggiornamenti sw o installato altri pacchetti? Potrebbe essere quello… ;)

  68. Argo scrive:

    Ho provato anch’io il mio output:

    [ 34.946892] PCI: Setting latency timer of device 0000:00:10.1 to 64
    [ 35.554790] fuse init (API version 7.8)
    [ 35.641602] lp: driver loaded but no devices found
    [ 36.057968] Adding 2626588k swap on /dev/disk/by-uuid/66eae444-9007-4673-aec8-bf7091dc8366. Priority:-1 extents:1 across:2626588k
    [ 36.239835] EXT3 FS on hda1, internal journal
    [ 42.418081] Using specific hotkey driver
    [ 42.514147] ibm_acpi: ec object not found
    [ 42.583242] ACPI: Battery Slot [BAT0] (battery present)
    [ 42.598911] input: Power Button (FF) as /class/input/input4
    [ 42.599216] ACPI: Power Button (FF) [PWRF]
    [ 42.600602] input: Lid Switch as /class/input/input5
    [ 42.600887] ACPI: Lid Switch [LID0]
    [ 42.626095] input: Sleep Button (CM) as /class/input/input6
    [ 42.626395] ACPI: Sleep Button (CM) [SLPB]
    [ 42.638104] input: Power Button (CM) as /class/input/input7
    [ 42.638393] ACPI: Power Button (CM) [PWRB]
    [ 42.745803] ACPI: AC Adapter [ADP1] (off-line)
    [ 42.756118] No dock devices found.
    [ 42.763844] ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
    [ 42.764034] ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
    [ 42.833967] pcc_acpi: loading…
    [ 43.086208] powernow-k8: Found 2 AMD Turion(tm) 64 X2 Mobile Technology TL-50 processors (version 2.00.00)
    [ 43.086263] powernow-k8: 0 : fid 0×8 (1600 MHz), vid 0×13
    [ 43.086268] powernow-k8: 1 : fid 0×0 (800 MHz), vid 0x1e
    [ 47.764549] ppdev: user-space parallel port driver
    [ 49.644200] NET: Registered protocol family 10
    [ 49.644321] lo: Disabled Privacy Extensions
    [ 49.644384] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 56.043208] ath0: no IPv6 routers present
    [ 213.832562] ath0: no IPv6 routers present

    la mia e’ una webcam integrata. Non ho fatto aggiornamenti ne installato altri pacchetti (io)…
    Voi ci capite qualcosa?!?!?!?!

  69. spit scrive:

    è l’orbicam. Mi fa impazzire, non ho fatto alcun aggiornamento, ma sono arrivato alla conclusione che sia un problema hardware perchè dando lsusb a colpi non me la da, se smanetto un po’ girandola poi la rileva e con mencoder mi da in output una finestra del tutto verde. Riavviando senza toccarla rifunziona. mah…

  70. Vova scrive:

    Hallo. You see, I have an acer laptop and use Linux Ubuntu and Mandriva sometimes. So i see you are speaking about orbicam. Unfochently I don`t understand your language, so can you write ore explain the same on english? It would be the best.

  71. paper0k scrive:

    @Vova
    You can found an english translation of this post here http://ubuntuforums.org/showthread.php?t=322218 ;)

  72. Gerardo scrive:

    Io ho la Aspire 9410Z e ho lo stesso problema, la webcam non funziona e appare un messaggio di Windows dicendo che ha smesso di funzionare, per favore qualcuno mi aiuti!!

  73. paper0k scrive:

    @Gerardo
    Sicuro che sia una orbicam o comunque una webcam supportata dai driver gspca?
    Con l’output di “lsusb” controlla qui http://mxhaard.free.fr/spca5xx.html se la webcam è supportata ;)
    Per Win spiacente ma non posso esserti di aiuto…

  74. ARY&MARY scrive:

    cazzoooooooooooooooooooooooooooo!!!!!!!!!!!!! nn mi si attivaaaaaaaaaa!!!!!!!!!!! uffaaaaaaaaaaaa!!!!!!!! cm si fa???? potete essere csi gentili da dircelo??? i love you

  75. ARY&MARY scrive:

    MAGARI…SE RISPONDESSE QUALCUNO…

  76. paper0k scrive:

    Per prima cosa questo non è un forum o una chat, se ti serve supporto immediato non è certo questo lo strumento ed il modo più adatto, vedi questo link http://www.ubuntu-it.org/index.php?page=supporto-della-comunita

    Secondo, in base alle informazioni fornite vedo difficile un’analisi………..

  77. miss ro scrive:

    scusate tanto io ho un acer aspire 5601awlmi e ho scaricato, dopo aver formattato il notebook, tutti i driver necessari per il funzionamento del portatile, compreso quello per la webcam (acer orbicam) quando accedo al programma, lo stesso fa apparire una finestra di dialogo che mi “informa” che la videocamera nn è collegata, peccato che sia integrata al pc…
    qualcuno può aiutarmi a risolvere il problema grazie!

  78. paper0k scrive:

    Ciao miss ro
    Stiamo parlando di GNU/Linux esatto? Hai seguito questa guida per la Orbicam su GNU/Linux? Hai controllato se l’output di “lsusb” è contemplato in questa lista http://mxhaard.free.fr/spca5xx.html ? ;)

  79. aleritty scrive:

    Ciao! ho scoperto che il driver V4L2 supporta molto bene tutte queste webcam, anche io ho un acer aspire ed lsusb mi da
    046d:09b0 Logitech, Inc.
    però se provate con ekiga, va direttamente senza installare nulla (perchè evidentemente usa questo driver) con camorama non sono ancora riuscito a farla andare!
    Ah, con aMsn va pure… anche lui usa questo driver, invece se si tenta con gspca (almeno a me non va) io ho feisty aggiornato ad oggi (ma andava anche ieri… ;-) )
    E non ho repo strani… sempre tutto di serie (a parte amsn scaricato aggiornato dal sito di alvaro!)

  80. carlo scrive:

    MI associo ai ringraziamenti.
    E’ bastato seguire passo-passo le tue indicazioni e voilà
    CAMORAMA funge su UBUNTU 7.04 su ACER ASPIRE 5630
    Ce ne fossero di persone come te!

  81. damiano scrive:

    ho un acer 5670 e la webcam non funziona. Ho formattato il computer ho scaricato i driver ed il sw dal sito acer ma quando vado per utilizzarla mi dice che la stessa non è collegata. Ho letto tutti i precedenti commenti ma io uso il sistema operativo Windows XP Home Edition e quindi non sono riuscito a fare nulla. C’e’ qualcuno che può idicarmi come fare? Grazie.

  82. paper0k scrive:

    Spiacente, ma non uso WinXP… uso solamente GNU/Linux ;)

  83. riccardo scrive:

    Bus 002 Device 002: ID 0402:5602 ALi Corp.
    ho un acer 5101awlmi con ubuntu tutto ok,, ma per la cam non sò come faccio a farla funzionare. mi potete aiutare? ciao grazie

  84. paper0k scrive:

    @riccardo
    Per la tua webcam, come consigliato qualche commento fa, vedi qui

    http://www.actiongames.co.uk/m560x/forum/index.php

    e qui

    https://sourceforge.net/projects/m560x-driver/
    ;)

  85. snapshot83 scrive:

    @riccardo: ho il tuo identico pc…io ci sbatto da un anno..non c’è nulla da fare ancora..e credo, di sto passo, nè ora nè mai…

  86. dhienger scrive:

    buona sera a tutti volevo dirvi che io ho formattato il mio portatile ASPIRE 5601AWLMI ma i driver non li ho dove li posso prendere o scaricare?!?plz aiutatemi!grazie mille in anticipo!

  87. paper0k scrive:

    Questa guida dovrebbe andar bene (vedi i commenti prima di questo) per un Acer 5601, per sicurezza, controlla l’output del comando “lsusb” ;)

    PS-Ovviamente qui si parla solo di GNU/Linux, per Win non saprei come aiutarti :)

  88. aureliano scrive:

    ciao paperok ho un problema
    quado do il comando sudo apt-get install build-essential linux-headers-$(uname -r)
    lui mi risponde che
    E: impossibile trovare build essential
    aiutami!!!

  89. aureliano scrive:

    il primo problema l’ho superato
    ora mi si presenta davanti un’altra difficolta’
    quando vado ad installare camorama (sudo apt-get install camorama) non mi funge
    allora mi sn scaricato il file compresso me lo sn decompresso in una cartella e ho eseguito il comando per configurarlo (./configure) mi si è configurato da solo (anche se ho dovuto installare dei componenti XML) e ora quando gli dico “make” lui mi risponde che *** No target specified and no makefile found. stop.
    qui mi sn veramente arenato…

  90. makefileaureliano scrive:

    posto un’ultima cosa e poi smetto di intasarti il sito :)
    premetto che ho linux da un giorno quindi sn veramente un caprone
    non so quanto possa essere utile ai fini della tua analisi ma ho notato che nella cartella di camorama non c’è un file denominato Makefile (e basta) come nella cartella del driver che ho scaricato (versione aggiornata 20071224) ma ci sn due file chiamati makefile.am e makefile.in
    grazie 1000 in anticipo!!

  91. paper0k scrive:

    @aureliano
    Per prima cosa… Hai controllato se l’output di “lsusb” è contemplato in questa lista http://mxhaard.free.fr/spca5xx.html ? ;)
    Cmq non occorre installare camorama dai sorgenti, prova a lanciare la versione installata con apt-get da terminale, forse vengono visualizzati degli errori che possono essere utili
    Inoltre, se non funziona ancora, guarda cosa restituisce il comando
    dmesg|tail -40
    forse il problema non è di camorama ma dei driver ;)

  92. sanguinela scrive:

    scusa….mi puoi dire che tag usi per scrivere il codice delle tue guide?? grazie

  93. paper0k scrive:

    Ciao sanguinela
    uso quello standard dell’editor di wordpress ed alcune volte allego HTML di codice preso da vim ;)

  94. anastasia scrive:

    fino a qui ci sono arrivata ho scaricato il pacchetto gspcavi-20071224.tar, lo apro ma non c’è niente per installare forse devo scaricare…kernel-headers ed il pacchetto build-essential, ma dove lo trovo, come faccio, HELP ME!!!
    Ciao a tutti

  95. pasquale scrive:

    ciao ragazzi a me non funziona la web sull’aspire 5672…. ma sinceramente non ho capito cosa devo fare… se qualcuno è disposto a dami un aiuto!!!!! ciao..

  96. angelotangredi scrive:

    cortese paperOK,
    ho una installazione di Ubuntu 7.10, Gutsy Gibbon su acer TM 4222 e la solita orbicam/logitec:

    telecamera ok al primo colpo (tranne per i colori corretti con il suo ottimo suggerimento) vorrei però segnalare un problema, il mio: la risoluzione è “solo” 320×240 (qualunque altra non viene visualizzata), desidero invece sfruttare la risoluzione 640×480 (ed eventualmente superiori grazie all’interpolazione).
    Si può?
    Si riesce a migliorare il fastidioso effetto grana? Si tratta (parlando con i termini del vecchio 35mm) di uno strano effetto pixel ed una piccola variazione cromatica verso le tonalità fredde.

    grazie mille, angelo

  97. paper0k scrive:

    @angelotangredi
    Spiacente non so come aiutarti, ma se trovi la risposta… fammi sapere ;)

  98. TRAVELMATE 4220 scrive:

    ciao a tutti volevo un grande aiuto. è da un po che la mia cam non funziona ho provato a disinstallare e reinstallare i draiver ma nulla. cosa dovrei fare?

  99. paper0k scrive:

    @ TRAVELMATE 4220
    MMM… Bisognerebbe avere più informazioni, ad esempio se hai installato altri drivers, nuovo hardware, qualcosa che potrebbe andare in conflitto … Comunque, come sempre, ti consiglio di aprire anche un post su http://forum.ubuntu-it.org segnalando il problema che hai riscontrato ;)

  100. Pingback: Instalando Ubuntu 2 de 2 | Acatos

  101. Christian M scrive:

    a me e’ sempre andata, male pero’ e’ sempre andata. Durante il boot il riconoscimento hw andava in sbattimento e siccome su queste cose linux e’ una vera ciofeka essendoci timeout assurdi il boot durava dai 10 ai 15minuti. Dovevo quindi disabilitare il driver e ricaricarlo a mano, ecce.eccc. Questa e’ una delle ragione per cui trovo questo OS molto immaturo per il mercato desktop, provate windows7, questo il mio consiglio, e se vi piace ed e’ all’altezza delle aspettative compratevi la licenza, potete sempre usare il sw libero anche su win, che gira pure meglio e senza casini di sorta. Ho a casa un server con linux che funziona egregiamente, sono anche sistemista unix da 10anni ormai, come desktop questo OS attualmente ha grandi speranze ma per il momento non riesce a fare quel salto di qualita’ che gli consentirebbe almeno di andare alla pari con il suo rivale di redmond.

  102. paper0k scrive:

    Ovviamente non condivido molto quanto da te esposto, se i driver venissero rilasciati dai produttori molti dei problemi che vengono rilevati su GNU/Linux, probabilmente, non ci sarebbero.
    Per il discorso Desktop invece, per me, GNU/Linux è già da parecchio tempo un Sistema Operativo valido, ci sono già tutti gli strumenti necessari per un utenza casalinga ed anche professionale. Non voglio certo prendere me come esempio, ma le persone che ho aiutato a passare a GNU/Linux in questi anni, non sono informatici ma casalinghe/studenti/meccanici/… che hanno anche perso l’abitudine di formattare e reinstallare quando qualcosa non va :D
    Comunque, per me, ognuno ha il diritto di scegliere il Sistema Operativo che preferisce, non sarò certo io a far cambiare loro idea ;)

  103. Eddie scrive:

    Salve! Ecco il mio problema: ho un Acer Aspire 9410z, con webcam integrata Orbicam.
    Lanciando lsusb, rileva correttamente la webcam come indicato nel post, poi faccio la procedura scritta per installare i kernel, il sistema controlla e mi dice che ho già tutto aggiornato all’ultima versione.
    Però provando Camorama, dice la solita frase Could not connect to video device….!
    Grazie in anticipo per qualunque aiuto!

  104. iari scrive:

    Ciao paperOk, ho un ACER Aspire 5630, ho seguito alla lettera le tue istruzioni, ma al passo “make”, il mio ubuntu 8.10 mi ha dato i seguenti errori:

    /usr/local/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
    /usr/local/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
    /usr/local/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
    /usr/local/gspcav1-20071224/gspca_core.c: At top level:
    /usr/local/gspcav1-20071224/gspca_core.c:2604: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
    /usr/local/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
    /usr/local/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
    /usr/local/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
    /usr/local/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
    /usr/local/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
    /usr/local/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
    /usr/local/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
    /usr/local/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
    /usr/local/gspcav1-20071224/gspca_core.c: At top level:
    /usr/local/gspcav1-20071224/gspca_core.c:4407: fatal error: opening dependency file /usr/local/gspcav1-20071224/.gspca_core.o.d: Permission denied
    compilation terminated.
    make[2]: *** [/usr/local/gspcav1-20071224/gspca_core.o] Error 1
    make[1]: *** [_module_/usr/local/gspcav1-20071224] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-9-generic’
    make: *** [default] Error 2

    puoi aiutarmi?
    Grazie,
    Iari.

  105. paper0k scrive:

    @ Eddie
    Dovresti verificare se il device (usando l’output del comando “lsusb”) è supportato dal driver, vedi qui http://mxhaard.free.fr/spca5xx.html ;)

    @ iari
    gspca ormai è integrato nei moduli del kernel rilasciati ufficialmente con Ubuntu, quindi non occorre eseguire la compilazione ;)

  106. iari scrive:

    anche ignorando l’errore e proseguendo con i comandi elencati, ottengo:

    iari@ubuntu:~$ lsusb
    Bus 005 Device 002: ID 046d:0896 Logitech, Inc. OrbiCam
    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    iari@ubuntu:~$ cd /usr/local/gspcav1-20071224/
    iari@ubuntu:/usr/local/gspcav1-20071224$ sudo make install
    [sudo] password for iari:
    mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
    rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
    rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
    install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
    install: cannot stat `gspca.ko’: No such file or directory
    make: *** [install] Error 1
    iari@ubuntu:/usr/local/gspcav1-20071224$ sudo gedit /etc/modprobe.d/options

    iari@ubuntu:/usr/local/gspcav1-20071224$
    iari@ubuntu:/usr/local/gspcav1-20071224$ sudo modprobe gspca
    FATAL: Module gspca not found.
    iari@ubuntu:/usr/local/gspcav1-20071224$ ls /dev/video*
    /dev/video0
    iari@ubuntu:/usr/local/gspcav1-20071224$ dmesg|tail -30
    [ 34.297821] Registered led device: iwl-phy0:assoc
    [ 34.297851] Registered led device: iwl-phy0:RX
    [ 34.297881] Registered led device: iwl-phy0:TX
    [ 34.459142] NET: Registered protocol family 17
    [ 81.320486] CPU0 attaching NULL sched-domain.
    [ 81.320506] CPU1 attaching NULL sched-domain.
    [ 81.341284] CPU0 attaching sched-domain:
    [ 81.341297] domain 0: span 0-1 level MC
    [ 81.341301] groups: 0 1
    [ 81.341309] domain 1: span 0-1 level NODE
    [ 81.341313] groups: 0-1
    [ 81.341322] CPU1 attaching sched-domain:
    [ 81.341325] domain 0: span 0-1 level MC
    [ 81.341329] groups: 1 0
    [ 81.341335] domain 1: span 0-1 level NODE
    [ 81.341339] groups: 0-1
    [ 81.499037] wlan0: authenticate with AP 00:1d:8b:f8:2c:43
    [ 81.501337] wlan0: authenticated
    [ 81.501349] wlan0: associate with AP 00:1d:8b:f8:2c:43
    [ 81.503775] wlan0: RX AssocResp from 00:1d:8b:f8:2c:43 (capab=0×411 status=0 aid=1)
    [ 81.503783] wlan0: associated
    [ 88.354337] NET: Registered protocol family 10
    [ 88.355227] lo: Disabled Privacy Extensions
    [ 88.357126] ADDRCONF(NETDEV_UP): eth0: link is not ready
    [ 98.600132] wlan0: no IPv6 routers present
    [ 502.628002] CE: hpet increasing min_delta_ns to 15000 nsec
    [ 775.700145] CE: hpet increasing min_delta_ns to 22500 nsec
    [ 1583.905147] type=1505 audit(1231884108.931:5): operation=”profile_replace” name=”/usr/share/gdm/guest-session/Xsession” name2=”default” pid=8004
    [ 1584.085631] type=1505 audit(1231884109.111:6): operation=”profile_replace” name=”/usr/lib/cups/backend/cups-pdf” name2=”default” pid=8009
    [ 1584.085990] type=1505 audit(1231884109.111:7): operation=”profile_replace” name=”/usr/sbin/cupsd” name2=”default” pid=8009
    iari@ubuntu:/usr/local/gspcav1-20071224$ sudo apt-get install camorama
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Lettura informazioni sullo stato… Fatto
    I seguenti pacchetti NUOVI (NEW) saranno installati:
    camorama
    0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
    È necessario prendere 211kB di archivi.
    Dopo quest’operazione, verranno occupati 1536kB di spazio su disco.
    Get:1 http://it.archive.ubuntu.com intrepid/universe camorama 0.19-2 [211kB]
    Scaricato 211kB in 0s (301kB/s)
    Selezionato il pacchetto camorama, che non lo era.
    (Lettura del database … 108420 file e directory attualmente installati.)
    Spacchetto camorama (da …/camorama_0.19-2_amd64.deb) …
    Processing triggers for man-db …
    Configuro camorama (0.19-2) …

    Quando lancio camorama, si accende il led sulla webcam, compare l’icona sulla toolbar in alto, ma insieme alla dialog di camorama si apre un pop-up con l’errore “Unable to capture image.”
    Cosa sto sbagliando?

    • paper0k scrive:

      Come ti dicevo, non serve compilare… il modulo è già rilasciato in Ubuntu
      Visto che il “modprobe” ti restituisce errore, lancia questo comando
      sudo apt-get install --reinstall linux-ubuntu-modules-$(uname -r)
      in modo da reinstallare i moduli del kernel in uso, e quindi riprova a dare
      sudo modprobe gspca
      se non ti da errore, riavvia camorama ;)

  107. iari scrive:

    Purtroppo il risultato non è cambiato:

    iari@ubuntu:~$ sudo apt-get install –reinstall linux-ubuntu-modules-$(uname -r)[sudo] password for iari:
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Lettura informazioni sullo stato… Fatto
    E: Impossibile trovare linux-ubuntu-modules-2.6.27-9-generic
    iari@ubuntu:~$ sudo modprobe gspca
    FATAL: Module gspca not found.

    E’ come se mi mancasse il modulo 2.6.27-9-generic: non so se dipenda dal fatto che un amico linuxomane esperto mi aveva (solo apparentemente?) risolto un problema di disallineamento tra versione del kernel e quella sul repository che risultava inspiegabilmente + arretrata (2.6.27-7?), per cui, se non ho capito male, è stato fatto una sorta di downgrade per poi fare l’upgrade all’ultima versione disponibile (proprio la 2.6.27-9?) …
    Cosa posso fare?

  108. Stefano scrive:

    Da me non funziona quando faccio sudo make install … acer aspire 4630

  109. Stefano scrive:

    … volevo dire acer aspire 5630

  110. Stefano scrive:

    quindi mi consigli di fare:
    sudo apt-get install –reinstall linux-ubuntu-modules-$(uname -r)

    è scritto in questo modo?

    ps. io avevo trovato anche questo: http://linux-uvc.berlios.de/ ma non so se funziona…

    grazie cmq

    • paper0k scrive:

      No, intendevo dire che con le ultime versioni di Ubuntu i moduli già sono presenti sul sistema, e dovrebbero essere già caricariti
      Se lanci
      lsmod|grep gspca
      dovresti ottenere qualcosa di simile
      gspca 657872 0
      compat_ioctl32 11136 1 gspca
      videodev 30720 1 gspca
      usbcore 170288 4 gspca,ehci_hcd,uhci_hcd

  111. Stefano scrive:

    Stasera ci provo, però da synaptic ho aggiunto il modulo gspca… però purtroppo non funziona…
    Il comando che mi hai postato tu è solo per vedere se il modulo gspca è presente, vero?
    Nel caso sia presente, come presumo, come posso risolvere il problema?

    Grazie per la disponibilità

    • paper0k scrive:

      Si è per vedere se il modulo è già caricato… in teoria se così fosse da camorama dovresti poter usare la webcam, altrimenti bisognerà indagare …

      PS – Il pacchetto che vedi nei repos sono i sorgenti non il modulo

  112. davide scrive:

    ciao, ho fatto tutto ciò che mi hai consigliato e la webcam ha cominciato a funzionare, ma si vede malissimo e su amsn non funziona. come mai? ho ubuntu 8.10 su aspire 5610z con webcam logitech orbicam. grazie

  113. Marco scrive:

    Ciao, ho provato a seguire tutti i punti, ma aprendo camorama ottengo sempre il messaggio could not connect to device.
    questo è quello che mi esce quando provo a dare make:

    make -C /lib/modules/`uname -r`/build SUBDIRS=/home/marco/Scrivania/gspcav1-20071224 CC=cc modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.27-7-generic’
    CC [M] /home/marco/Scrivania/gspcav1-20071224/gspca_core.o
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c: At top level:
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2604: error: ‘v4l_compat_ioctl32’ undeclared here (not in a function)
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
    /home/marco/Scrivania/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
    make[2]: *** [/home/marco/Scrivania/gspcav1-20071224/gspca_core.o] Error 1
    make[1]: *** [_module_/home/marco/Scrivania/gspcav1-20071224] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-7-generic’
    make: *** [default] Error 2

    Qualche consiglio?
    p.s. ho un acer 5630, uso intrepid ed ho già seguito i consigli per il passaggio ad intrepid senza risultati
    Grazie

  114. Salvo scrive:

    Ciao, io sono nuovo di ubuntu quindi abbiate pietà…Io ho un aspire 5630, ho seguito la guida, però invece di crearmi /de/video0 mi crea /dev/video1…da cosa dipende??e più che altro, cosa più probabile, cosa ho sbagliato?

  115. paper0k scrive:

    @Marco
    probabilmente non hai installato gli headers
    sudo apt-get install linux-headers-$(uname -r)
    cmq, ripeto, con le ultime versioni di Ubuntu, il modulo è già presente e non occorre installarlo manualmente, dovrebbe già funzionarti tutto ;)

    @Salvo
    Probabilmente nessun errore, hai solo un altro dispositivo video collegato al PC ;)

  116. daniele scrive:

    ciao, scarico i pacchetti, ma al momento dell’istallazione mi da questo errore:

    daniele@daniele-laptop:~$ cd gspcav1-20071224/
    daniele@daniele-laptop:~/gspcav1-20071224$ make
    make -C /lib/modules/`uname -r`/build SUBDIRS=/home/daniele/gspcav1-20071224 CC=cc modules
    make[1]: Entering directory `/usr/src/linux-headers-2.6.27-11-generic’
    CC [M] /home/daniele/gspcav1-20071224/gspca_core.o
    /home/daniele/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: No such file or directory
    /home/daniele/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
    /home/daniele/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
    /home/daniele/gspcav1-20071224/gspca_core.c: At top level:
    /home/daniele/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
    /home/daniele/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
    /home/daniele/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
    /home/daniele/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
    /home/daniele/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
    /home/daniele/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
    /home/daniele/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
    /home/daniele/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
    /home/daniele/gspcav1-20071224/gspca_core.c: At top level:
    /home/daniele/gspcav1-20071224/gspca_core.c:4407: fatal error: opening dependency file /home/daniele/gspcav1-20071224/.gspca_core.o.d: Permission denied
    compilation terminated.
    make[2]: *** [/home/daniele/gspcav1-20071224/gspca_core.o] Error 1
    make[1]: *** [_module_/home/daniele/gspcav1-20071224] Error 2
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.27-11-generic’
    make: *** [default] Error 2
    daniele@daniele-laptop:~/gspcav1-20071224$

    questo è il mio lsusb:
    daniele@daniele-laptop:~$ lsusb
    Bus 007 Device 002: ID 0af0:6701 Option
    Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 003: ID 5986:0100 Acer, Inc Orbicam
    Bus 005 Device 002: ID 05e3:0702 Genesys Logic, Inc. USB 2.0 IDE Adapter
    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    daniele@daniele-laptop:~$

    ubuntu 8.10 aiuto please!

  117. daniele scrive:

    curiosita, perche con questo comando:
    sudo LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama
    riesco ad aprire camorama e la web funziona anche se con pessimi colori?
    mentre se provo ad aprire camorama direttamente non me lo apre e mi da errore?
    grazie

  118. stefano scrive:

    scusami, ma non capisco questo pasaggio quindi posizioniamoci nella cartella dove abbiamo eseguito il download:
    cd /path/cartella/download….c’è non mi riesce

  119. Salvo scrive:

    Ho provato ma niente…questa volta mi crea il video0 ma quando provo a far partire il programma mi da errore Could not connect to video device (/dev/video0). E’ strano perchè leggendo altri post, al mio stesso modello Acer Aspire 5630, nn hanno avuto problemi…

    Bus 005 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 004: ID 046d:09b0 Logitech, Inc. OrbiCam
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

  120. semplice.mente scrive:

    ciao a tutti,
    ho un acer aspire 5602 con debian in dual boot con win xp (anche se dopo l’ultimo, ennesimo, ripristino del sistema di win l’ho abbandonato e sto usando solo linux :))
    tempo fa (avevo etch) seguii una guda simile a questa e potevo usare tranquillamente l’orbicam logitech su debian.
    poi da qualche mese a questa parte la cam ha ‘deciso’ di non funzionare più:
    xp mi invita a “connettere l’hardware alla porta usb” (il che può sembrare assurdo perchè la cam è integrata), mentre lenny (ho aggiornato il so) non me la elenca più in lsusb ma all’avvio mi riporta l’errore usb 3-2: device descriptor read/64, error -71
    ora, prima di procedere con l’installazione dei driver gspca, possiamo concludere (anche per quelli che sono passati qui prima di me e sembrano essere nella stessa situazione) che è un problema hw? forse si è scollegato qualche filo all’interno… può essere?

  121. paper0k scrive:

    @stefano: Invece di “/path/cartella/download” devi mettere il path dove hai scaricato il file.
    Se usi una recente versione di Ubuntu, come ho detto il altre occasioni, non serve installare nulla, solo camorama o sw equivalente ;)

  122. paper0k scrive:

    @daniele: Con LD_PRELOAD vai ad indicare a camorama di utilizzare prima una certa libreria e poi quelle comuni. Nello specifico non so aiutarti, ma se scopri il perché, avvisami che potrebbe essere utile ad altri ;)

  123. paper0k scrive:

    @semplice.mente
    Ok, siamo in due! :D
    Oggi mi sono accorto che non funziona più la webcam…
    lsusb
    Bus 005 Device 001: ID 0000:0000
    Bus 004 Device 001: ID 0000:0000
    Bus 003 Device 001: ID 0000:0000
    Bus 002 Device 001: ID 0000:0000
    Bus 001 Device 001: ID 0000:0000

    e ovviamente…
    [ 253.749583] usb 2-2: device descriptor read/64, error -71
    [ 253.808251] usb 2-2: device descriptor read/64, error -71
    [ 253.869601] usb 2-2: new full speed USB device using uhci_hcd and address 21
    [ 253.907712] usb 2-2: device descriptor read/64, error -71
    [ 253.963072] usb 2-2: device descriptor read/64, error -71

    quindi… o abbiamo entrambi la webcam rotta o qualcosa non va…
    Girovagando ho trovato questo

    http://ubuntuforums.org/showthread.php?t=797789

    ma a me non ha funzionato…
    Ora non ho molto tempo per continuare, ma spero nei prossimi giorni di trovare la soluzione ;)

    • scimmia scrive:

      Siamo in tre :-), anzi cambio la faccina in :-(

      aggiornaci se ci sono novità! grazie.

      (ps, io son su debian sid, kernel 2.6.29)

      • scimmia scrive:

        automagicamente oggi ha ripreso ad andare.
        se indagando scopro qualcosa, farovvi sapere.

        voi continuate pure le indagini, non vorrei avesse un carattere completamente aleatorio!

  124. Luca scrive:

    Ciao sono Luca…
    Sono certo che approdato qui sono nel posto giusto.
    Acer Aspire 5580
    La cam integrata è assolutamente quella in questione.
    Ti posto il report copiato da terminale con gli errori che mi da
    durante l’instalalzione.Sono certo che è un mio errore banale di constatazione.Forse c’è qualcosa che non va nel mio kernel
    2.6.28-11-generic

    luco@luco-laptop:~$ sudo apt-get install build-essential linux-headers-$(uname -r)
    [sudo] password for luco:
    Lettura della lista dei pacchetti in corso… Fatto
    Generazione dell’albero delle dipendenze in corso
    Lettura informazioni sullo stato… Fatto
    build-essential è già alla versione più recente.
    linux-headers-2.6.28-11-generic è già alla versione più recente.
    0 aggiornati, 0 installati, 0 da rimuovere e 62 non aggiornati.
    luco@luco-laptop:~$ cd Scrivania
    luco@luco-laptop:~/Scrivania$ ls
    Blade Runner nuovo file (copia)~
    gspcav1-20071224.tar.gz pendrive
    new kernel deb report installazione fallita gspcav
    nuovo file~ test.txt
    luco@luco-laptop:~/Scrivania$ tar zxvf gspcav1-20071224.tar.gz
    gspcav1-20071224/
    gspcav1-20071224/decoder/
    gspcav1-20071224/decoder/gspcadecoder.c
    gspcav1-20071224/decoder/gspcadecoder.h
    gspcav1-20071224/decoder/gspcadecoder-OSX.c
    gspcav1-20071224/decoder/gspcadecoder-OSX.h
    gspcav1-20071224/Makefile
    gspcav1-20071224/Vimicro/
    gspcav1-20071224/Vimicro/vc032x_sensor.h
    gspcav1-20071224/Vimicro/zc3xx.h
    gspcav1-20071224/Vimicro/cs2102.h
    gspcav1-20071224/Vimicro/vc032x.h
    gspcav1-20071224/Vimicro/pas106b.h
    gspcav1-20071224/Vimicro/icm105a.h
    gspcav1-20071224/Vimicro/hv7131b.h
    gspcav1-20071224/Vimicro/hv7131c.h
    gspcav1-20071224/Vimicro/pb0330.h
    gspcav1-20071224/Vimicro/ov7630c.h
    gspcav1-20071224/Vimicro/mc501cb.h
    gspcav1-20071224/Vimicro/tas5130c_vf0250.h
    gspcav1-20071224/Vimicro/ov7620.h
    gspcav1-20071224/Vimicro/tas5130c.h
    gspcav1-20071224/Vimicro/hdcs2020.h
    gspcav1-20071224/Etoms/
    gspcav1-20071224/Etoms/et61xx51.h
    gspcav1-20071224/Sonix/
    gspcav1-20071224/Sonix/sn9cxxx.h
    gspcav1-20071224/Sonix/sonix.h
    gspcav1-20071224/utils/
    gspcav1-20071224/utils/spcagamma.h
    gspcav1-20071224/utils/spcausb.h
    gspcav1-20071224/utils/spcaCompat.h
    gspcav1-20071224/Conexant/
    gspcav1-20071224/Conexant/cx11646.h
    gspcav1-20071224/Conexant/cxlib.h
    gspcav1-20071224/Pixart/
    gspcav1-20071224/Pixart/pac207-OSX.h
    gspcav1-20071224/Pixart/pac7311.h
    gspcav1-20071224/Pixart/pac207.h
    gspcav1-20071224/changelog
    gspcav1-20071224/license
    gspcav1-20071224/gspca_core.c
    gspcav1-20071224/Transvision/
    gspcav1-20071224/Transvision/tv8532.h
    gspcav1-20071224/Makefile.kld
    gspcav1-20071224/gspca.h
    gspcav1-20071224/Sunplus/
    gspcav1-20071224/Sunplus/spca501.dat
    gspcav1-20071224/Sunplus/spca505.dat
    gspcav1-20071224/Sunplus/spca508.dat
    gspcav1-20071224/Sunplus/spca561-OSX.h
    gspcav1-20071224/Sunplus/spca506.h
    gspcav1-20071224/Sunplus/spca561.h
    gspcav1-20071224/Sunplus/spca501_init.h
    gspcav1-20071224/Sunplus/spca508_init-OSX.h
    gspcav1-20071224/Sunplus/spca508_init.h
    gspcav1-20071224/Sunplus/spca501_init-OSX.h
    gspcav1-20071224/Sunplus/spca505_init.h
    gspcav1-20071224/Sunplus-jpeg/
    gspcav1-20071224/Sunplus-jpeg/spca500.dat
    gspcav1-20071224/Sunplus-jpeg/jpeg_qtables.h
    gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.h
    gspcav1-20071224/Sunplus-jpeg/sp5xxfw2.dat
    gspcav1-20071224/Sunplus-jpeg/spca500_init.h
    gspcav1-20071224/gspca_build
    gspcav1-20071224/READ_AND_INSTALL
    gspcav1-20071224/Mars-Semi/
    gspcav1-20071224/Mars-Semi/mr97311.h
    gspcav1-20071224/cutlog.py
    luco@luco-laptop:~/Scrivania$ cd gspcav1-20071224/
    luco@luco-laptop:~/Scrivania/gspcav1-20071224$ make
    make -C /lib/modules/`uname -r`/build SUBDIRS=/home/luco/Scrivania/gspcav1-20071224 CC=cc modules
    make[1]: ingresso nella directory «/usr/src/linux-headers-2.6.28-11-generic»
    CC [M] /home/luco/Scrivania/gspcav1-20071224/gspca_core.o
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: Nessun file o directory
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c: At top level:
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
    /home/luco/Scrivania/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
    make[2]: *** [/home/luco/Scrivania/gspcav1-20071224/gspca_core.o] Errore 1
    make[1]: *** [_module_/home/luco/Scrivania/gspcav1-20071224] Errore 2
    make[1]: uscita dalla directory «/usr/src/linux-headers-2.6.28-11-generic»
    make: *** [default] Errore 2
    luco@luco-laptop:~/Scrivania/gspcav1-20071224$ sudo make install
    mkdir -p /lib/modules/`uname -r`/kernel/drivers/usb/media/
    rm -f /lib/modules/`uname -r`/kernel/drivers/usb/media/spca5xx.ko
    rm -f /lib/modules/`uname -r`/kernel/drivers/media/video/gspca.ko
    install -c -m 0644 gspca.ko /lib/modules/`uname -r`/kernel/drivers/usb/media/
    install: impossibile eseguire stat di “gspca.ko”: Nessun file o directory
    make: *** [install] Errore 1
    luco@luco-laptop:~/Scrivania/gspcav1-20071224$ uname -r
    2.6.28-11-generic
    luco@luco-laptop:~/Scrivania/gspcav1-20071224$

    Ho un errore al primo MAKE una volta nella cartella di scompattamento.
    Sai darmi un’aiuto?
    Devo smanettare con gli headers?
    Ubuntu jaunty da 2 mesi. No avanzamento da 8.10 ma direttamente trasloco da windows.Mi vede tutto tranne la cam.
    Grazie mille
    Luca

  125. Luca scrive:

    …e già che ci sono per darti certezza:

    luco@luco-laptop:~$ lsusb
    Bus 001 Device 004: ID 046d:0896 Logitech, Inc. OrbiCam
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 002: ID 062a:0000 Creative Labs Optical mouse
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    luco@luco-laptop:~$

    la webcam è lì riconosciuta ^.°

  126. vincenzo scrive:

    ciao, ho un acer aspire 5633wlmi e sono un novello di linux. utilizzo ubuntu 9.04 e vorrei far funzionare la mia webcam.
    lsusb mi restituisce
    Bus 001 Device 006: ID 046d:0896 Logitech, Inc. OrbiCam

    purtroppo seguendo questa guida incontro dei problemi

    1)
    digitando
    sudo apt-get install build-essential linux-headers-$2.6.28-15-generic
    mi restituisce
    build-essential è gia alla versione più recente
    Impossibile trovare linux-headers-.6.28-15-generic

    2)
    digitando
    sudo make install
    mi restituisce
    mkdir -p /lib/modules/’uname -r’/kernel/drivers/usb/media/
    rm -f /lib/modules/’uname -r’/kernel/drivers/usb/media/spca5xx.ko
    rm -f /lib/modules/’uname -r’/kernel/drivers/media/video/gspca.ko
    install -c -m 0644 gspca.ko /lib/modules/’uname -r’/kernel/drivers/usb/media/
    install: impossibile eseguire stat di “gspca.ko”: Nessun file o directory
    make: *** [install] Errore 1

  127. vincenzo scrive:

    allora, ho riscritto
    sudo apt-get install build-essential linux-headers-2.6.28-15-generic
    e sembra che lo ha accettato (notare che non c’è il $)

    comunque, ho rifatto make e mi restituisce questo:

    make -C /lib/modules/`uname -r`/build SUBDIRS=/home/vincenzo/gspcav1-20071224 CC=cc modules
    make[1]: ingresso nella directory «/usr/src/linux-headers-2.6.28-15-generic»
    CC [M] /home/vincenzo/gspcav1-20071224/gspca_core.o
    /home/vincenzo/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: Nessun file o directory
    /home/vincenzo/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
    /home/vincenzo/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
    /home/vincenzo/gspcav1-20071224/gspca_core.c: At top level:
    /home/vincenzo/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
    /home/vincenzo/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
    /home/vincenzo/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
    /home/vincenzo/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
    /home/vincenzo/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
    /home/vincenzo/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
    /home/vincenzo/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
    /home/vincenzo/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
    make[2]: *** [/home/vincenzo/gspcav1-20071224/gspca_core.o] Errore 1
    make[1]: *** [_module_/home/vincenzo/gspcav1-20071224] Errore 2
    make[1]: uscita dalla directory «/usr/src/linux-headers-2.6.28-15-generic»
    make: *** [default] Errore 2

  128. michimora scrive:

    la mia webcam sul acer aspire5633wlmi non va piu. cosa poso fare? ma non sono tanto pratica di usarlo.se lo sapete mi dite per favore

  129. luigi vecchi scrive:

    Ho un computer Acer ASPIRE 5101 AWLMi dove il programma della OBICAM è stato accidentalmente disistallato……….posso ricevere il file di installazione o informazioni di come fare per riattivare il problema? grazie e saluti Lugi Vecchio

    • paper0k scrive:

      Ciao Luigi
      qui parliamo di GNU/Linux, credo che tu ti stia riferendo all’installazione su Windows, mi dispiace ma non saprei come aiutarti

      Ciao

  130. Nic scrive:

    Ciao ho sempre seguito la tua guida per configurare la mia webcam integrata con Debian.
    Ora però con Ubuntu 9.04 non riesco.
    Il make si blocca e non riesco ad andare avanti:

    make -C /lib/modules/`uname -r`/build SUBDIRS=/home/nic/gspcav1-20071224 CC=cc modules
    make[1]: ingresso nella directory «/usr/src/linux-headers-2.6.28-18-generic»
    CC [M] /home/nic/gspcav1-20071224/gspca_core.o
    /home/nic/gspcav1-20071224/gspca_core.c:54:27: error: asm/semaphore.h: Nessun file o directory
    /home/nic/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_ioctl’:
    /home/nic/gspcav1-20071224/gspca_core.c:2463: error: implicit declaration of function ‘video_usercopy’
    /home/nic/gspcav1-20071224/gspca_core.c: At top level:
    /home/nic/gspcav1-20071224/gspca_core.c:2609: error: unknown field ‘owner’ specified in initializer
    /home/nic/gspcav1-20071224/gspca_core.c:2609: warning: initialization from incompatible pointer type
    /home/nic/gspcav1-20071224/gspca_core.c:2611: error: unknown field ‘type’ specified in initializer
    /home/nic/gspcav1-20071224/gspca_core.c: In function ‘spca50x_create_sysfs’:
    /home/nic/gspcav1-20071224/gspca_core.c:2769: error: implicit declaration of function ‘video_device_create_file’
    /home/nic/gspcav1-20071224/gspca_core.c:2780: error: implicit declaration of function ‘video_device_remove_file’
    /home/nic/gspcav1-20071224/gspca_core.c: In function ‘spca5xx_probe’:
    /home/nic/gspcav1-20071224/gspca_core.c:4301: error: incompatible types in assignment
    make[2]: *** [/home/nic/gspcav1-20071224/gspca_core.o] Errore 1
    make[1]: *** [_module_/home/nic/gspcav1-20071224] Errore 2
    make[1]: uscita dalla directory «/usr/src/linux-headers-2.6.28-18-generic»
    make: *** [default] Errore 2

    hai idee su come risolvere?
    Grazie e ciao

    • paper0k scrive:

      Con le nuovi versioni di Ubuntu, il driver è già presente e non necessita quindi di essere installato ;)

      • Thd_web scrive:

        Ciao paper0k!!
        ho appena installato Ubuntu 9.10 su un vecchio ACER aspire 5672. (premetto che ho un acer 3100 e un acerino one con ubuntu e che vanno benissimo…)
        Tornando al 5672 funziona tutto eccetto la web cam. Ho seguito la guida dall’inizio ( e mi si ferma al make finale con 2 errori) , ho provato a installare di tutto ma nessun programma riesce a farla funzionare.
        Il Comando “sudo LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so camorama” precedentemente proposto mi fa funzionare la Web-cam male,
        Viene riconosciuta come “Bus 001 Device 003: ID 046d:0892 Logitech, Inc. OrbiCam”
        Se hai tempo si accettano consigli :) Grazie! Thomas

      • paper0k scrive:

        Con le nuove versioni è già presente il modulo, se lanci da terminale
        lsmod|grep gspca
        lo dovresti già trovare caricato. Ed usa camorama per vedere se funziona, potrebbe solo essere un problema con skype o quello che stai usando. Se fai una ricerca nel forum di ubuntu sicuramente trovi qualcosa ;)

  131. William Lanza scrive:

    Ho installato Windows 7 Home Premium nel mio Aspire 5630 che aveva originalmente Windows Vista Home Premium, tutto bene tranne che non riesco a trovare i driver per la Orbi cam integrata sul portatile. Sarebbe cosi gentile di darmi una dritta di come risolvere il problema. Grazie mille.William

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

Iscriviti

Ricevi al tuo indirizzo email tutti i nuovi post del sito.

Unisciti agli altri 113 follower

%d blogger cliccano Mi Piace per questo: